[Box Backup-commit] [boxbackup/boxbackup] fa6e3a: Remove duplicate code from BackupAccountControl, s...

GitHub noreply at github.com
Fri Oct 16 23:23:28 BST 2015

  Branch: refs/heads/s3_support_merge
  Home:   https://github.com/boxbackup/boxbackup
  Commit: fa6e3a17160710b9405c4db6e03701e5029e6505
  Author: Chris Wilson <chris+github at qwirx.com>
  Date:   2015-10-16 (Fri, 16 Oct 2015)

  Changed paths:
    M lib/backupstore/BackupAccountControl.cpp
    M lib/backupstore/BackupAccountControl.h

  Log Message:
  Remove duplicate code from BackupAccountControl, simplify API.

Remove confusing URL functions, replace with calls to better-defined
BackupFileSystem functions.

Remove useless proxies for GetObject and PutObject.

More information about the Boxbackup-commit mailing list