[Box Backup] Problems doing a new install

Ben Summers boxbackup at fluffy.co.uk
Mon Dec 12 21:58:36 GMT 2005


On 12 Dec 2005, at 21:48, Remco Poelstra wrote:

> Hi,
>
> I've a new server, on which I'm trying to install boxbackup.
> I've compiled it on a Fedora Core 4 machine (the client) and the  
> server is Debian sarge. Now bbstoreaccounts is complaining about  
> the stdc++ lib not being (compiled with) the right version. This  
> could very well be, given the fact that I used a parcel to install  
> boxbackup.
> Is it possible to compile a static version so I won't have that  
> problem? I can't compile it on my server, because there is no  
> compiler installed on it....

You can add extra options to the compile and link lines with  
arguments to ./configure, for example,

	./configure compile:-I/usr/local/include link:-L/usr/local/lib

So, just work out what options are needed to do what you want, and  
include them.

Good luck!

Ben







More information about the Boxbackup mailing list