[Box Backup] new disk -> error 1/9 Error accessing a file. Check permissions.

Ben Summers boxbackup at fluffy.co.uk
Thu Dec 15 21:56:03 GMT 2005


On 15 Dec 2005, at 21:43, Andreas Schrafl wrote:

> Hi
>
> I changed my server by putting the disk into a new machine (same  
> network cards) and added a disk. now everything went well except box.
>
> I move to the files to the new disk with cp -R -p and changed  
> raidfile.conf to the new path (I don't have a raid so 3 times the  
> same path).
> Now when I start box it runs but can't access the accounts.
>
> I get this in the log:
>
> bbstored[21972]: Starting daemon (config: /etc/box/bbstored.conf)  
> (version 0.09)
> bbstored/hk[30903]: Housekeeping process started
> bbstored/hk[30903]: Starting housekeeping
> bbstored/hk[30903]: while housekeeping account 000003E8, exception  
> Common OSFileError (Error accessing a file. Check permissions.)  
> (1/9) -- aborting housekeeping run for this account
> bbstored/hk[30903]: while housekeeping account 000007D0, exception  
> Common OSFileError (Error accessing a file. Check permissions.)  
> (1/9) -- aborting housekeeping run for this account
> bbstored/hk[30903]: while housekeeping account 00000BB8, exception  
> Common OSFileError (Error accessing a file. Check permissions.)  
> (1/9) -- aborting housekeeping run for this account
> bbstored/hk[30903]: while housekeeping account 00000FA0, exception  
> Common OSFileError (Error accessing a file. Check permissions.)  
> (1/9) -- aborting housekeeping run for this account
> bbstored/hk[30903]: Finished housekeeping
>
> So I checked the config files and the data files and all have  
> permission for _bbstored (since I copied it with -p).
>
> Now I know I should have tested everything with just the new disk  
> or just the new computer but I made both and if I undo the disk  
> change (change back the raidfile.conf) I get exactly the same error.
>
> Could it be something with the encryption?

Only relevant for the client.

> I thougt I didn't change anything there since I just took out the  
> disk of one machine and pluged it into the other (you can do this  
> with OpenBSD).

No reason this shouldn't work.

Can you post your raidfile.conf, bbstored.conf, and an ls -la of the  
directory the raidfile.conf points to?

Ben





More information about the Boxbackup mailing list