[Box Backup] 100% cpu load on server when connected

Mikael Syska boxbackup at fluffy.co.uk
Thu Jan 5 14:40:07 GMT 2006


Hi,

When my client ( FreeBSD 5.4 ) are connected the server ( Gentoo 2.6.14 
) uses 100% CPU on "bbstored" process.... its not transfering any data.

The Client remains connected all the time, until I "kill -9 processid" 
or it finishes after 1 hour and 8 mins.

Its runs over a 100 Mbit LAN connection

I have run "bbstoreaccounts check 1" and theres not any errors/corruptions

Jan  5 12:29:00 thunder bbackupd[79214]: Starting daemon (config: 
/usr/local/etc/box/bbackupd.conf) (version 0.09)
Jan  5 12:29:00 thunder bbackupd[79214]: Beginning scan of local files

Jan  5 12:29:00 thunder bbackupd[79214]: Opening connection to server 
laptop.syska.dk...
Jan  5 12:29:01 thunder bbackupd[79214]: Connection made, login successful
Jan  5 13:37:27 thunder bbackupd[79214]: Finished scan of local files
Jan  5 13:37:27 thunder bbackupd[79214]: File statistics: total file 
size uploaded 390583, bytes already on server 0, encoded size 2
00261
Jan  5 13:37:27 thunder bbackupd[79214]: Beginning scan of local files
Jan  5 13:37:27 thunder bbackupd[79214]: Opening connection to server 
laptop.syska.dk...
Jan  5 13:37:27 thunder bbackupd[79214]: Connection made, login successful
Jan  5 13:37:37 thunder bbackupd[79214]: Finished scan of local files
Jan  5 13:37:37 thunder bbackupd[79214]: File statistics: total file 
size uploaded 25822, bytes already on server 0, encoded size 10
796

As I can see here the whole process takes about 1 hour and 8 mins? are 
that correct? and it transfered 381 Kbyte......?

( using ifstat to see the bandwidth usage.... its at 0.7 kbyte/sec at 
all the time except when it transfers the new files.... )

any hints what might cause this behavior?

best regards
Mikael Syska



More information about the Boxbackup mailing list