[Box Backup] Restore Symlinks

Andreas Schrafl boxbackup at fluffy.co.uk
Tue Oct 31 17:52:10 GMT 2006


The problem occurred when restoring to a OpenBSD 4.0 box.
The server was is a OpenBSD 3.9 machine. As I reported when running the 
restore on a windows it works.
I also tried to restore to the server so no OS differences there (the 
machine that was backuped was 3.7 but that should not be of any interest 
for a backup application)

I've run ./runtest.pl ALL on the server (where I compiled the files) for 
the 0.09 and the 0.10 version:

0.09:
PASSED
Block 7c6723c0 freed, but not known. Error? Or allocated in startup 
static allocation?
--------
common: PASSED
crypto: PASSED
compress: FAILED: Exception caught: St9bad_alloc
basicserver: PASSED
raidfile: PASSED
backupstore: Block 8bd9b200 freed, but not known. Error? Or allocated in 
startup static allocation?
backupstorefix: PASSED
backupstorepatch: Block 7fa751c0 freed, but not known. Error? Or 
allocated in startup static allocation?
backupdiff: Block 7e6f5000 freed, but not known. Error? Or allocated in 
startup static allocation?
bbackupd: Block 7c6723c0 freed, but not known. Error? Or allocated in 
startup static allocation?


0.10:
PASSED
--------
common: PASSED
crypto: PASSED
compress: FAILED: Exception caught: St9bad_alloc
basicserver: PASSED
raidfile: PASSED
backupstore: PASSED
backupstorefix: PASSED
backupstorepatch: PASSED
backupdiff: PASSED
bbackupd: PASSED

So there seem to be some issues. I'm not sure what they mean (not a 
programmer) but perhaps you all can tell me.

Ben Summers wrote:
> 
> Andy
> 
> What platform are you using?
> 
> Could you run the tests on your client, and see if you get any failures? 
> Symlink support is explicitly tested with a backup and restore cycle.
> 
> Ben
> 
> 
> 
> On 30 Oct 2006, at 15:04, Andreas Schrafl wrote:
> 
>> I'm very glad I used BoxBackup. Saved all my data after a raid crashed 
>> and the restore shreddered the data that was left.
>>
>> Now I encountered some problem while restoring concerning symlinks.
>>
>> Simply it didn't restore them. I had several symlinks like form one 
>> directory to an other (same mountpoint). These symlink just would not 
>> be restored.
>>
>> One symlink even crashed the bbackupquery session repeatedly and so I 
>> had to restore everything surrounding this directory separately.
>> I tried to fix it on the server (checking the account and fixing it) 
>> but there were no errors so nothing to fix.
>>
>> I extracted this directory to a windows machinne and there it just 
>> skipped these files.
>>
>> Perhaps this got fixed lately (still using 0.09 but I could not find 
>> anything on this topic).
>>
>> Thanks for the nice backuptool it really is simple an useful.
>> Andy
>>
>> PS: are there any special things to look out for when updating a 
>> server from 0.09 to 0.10?
>> _______________________________________________
>> boxbackup mailing list
>> boxbackup at fluffy.co.uk
>> http://lists.warhead.org.uk/mailman/listinfo/boxbackup
> 
> _______________________________________________
> boxbackup mailing list
> boxbackup at fluffy.co.uk
> http://lists.warhead.org.uk/mailman/listinfo/boxbackup

-- 
Andreas Schrafl
Unterdorfstrasse 19
8124 Maur
Switzerland

Tel.: 	+41 (0)44 980 3842
Mobile: +41 (0)76 433 3842
Fax:    +41 (0)44 980 4031
E-mail: andy at jetnet.ch
Web:    personal.jetnet.ch/andy



More information about the Boxbackup mailing list