[Box Backup] Non-ASCII file and folder names crash Boxi at restore but not at backup

Chris Wilson boxbackup at boxbackup.org
Mon Apr 20 21:46:41 BST 2009


Hi Achim,

On Mon, 20 Apr 2009, Achim wrote:

> I am more than a bit surprised that nobody else is using the fantastic 
> Boxi in a non-English (non-ASCII) environment, or did really nobody else 
> encounter the filename issues that I tried to outline in my message from 
> 8 April?

I doubt that many people are using Boxi at all. The last published binary 
is quite old and missing a lot of important features.

> Any hints on where to start debugging (gdb) or looking for how Boxi 
> (which is broken for these filenames) uses Box Backup (which works just 
> fine) would be very welcome.

I would concentrate on saving and loading of configuration files. The best 
thing to do would be to write a test case that creates a ClientConfig 
object, puts some non-ASCII directory names into it, saves it to a file 
and loads it again, and checks that the names are still correct. I suspect 
that this is where the problem is.

I was trying to figure out how to put Unicode characters into C++ strings 
(wxWidgets wxString objects) but I haven't worked it out yet.

Cheers, Chris.
-- 
_____ __     _
\  __/ / ,__(_)_  | Chris Wilson <0000 at qwirx.com> - Cambs UK |
/ (_/ ,\/ _/ /_ \ | Security/C/C++/Java/Ruby/Perl/SQL Developer |
\__/_/_/_//_/___/ | We are GNU : free your mind & your software |



More information about the Boxbackup mailing list