[Box Backup] Non-ASCII file and folder names crash Boxi at restore but not at backup

Achim boxbackup at boxbackup.org
Tue Apr 21 14:28:47 BST 2009


Hello Chris:

On Mon, 20 Apr 2009 21:46:41 +0100 (BST), Chris Wilson <chris at qwirx.com>
wrote:
> I doubt that many people are using Boxi at all. The last published binary

> is quite old and missing a lot of important features.

What do you think about making the latest builds available for download for
Windows? My company would be happy to sponsor the builds and the download
location, perhaps this will expose Boxi to more potential testers.

I really think that there is very little missing to turn Boxi into a great
enduser tool.

>> Any hints on where to start debugging (gdb) or looking for how Boxi 
>> (which is broken for these filenames) uses Box Backup (which works just 
>> fine) would be very welcome.
> 
> I would concentrate on saving and loading of configuration files. The
best 
> thing to do would be to write a test case that creates a ClientConfig 
> object, puts some non-ASCII directory names into it, saves it to a file 
> and loads it again, and checks that the names are still correct. I
suspect 
> that this is where the problem is.

OK, I will try to do that. 

The configuration files are definitely one area of problems. Another one
are the actual names of the backed up files: For instance, backing up with
Box Backup works fine for ä.test, but restoring with Boxi fails (as
outlined in more details in my earlier message).

> I was trying to figure out how to put Unicode characters into C++ strings

> (wxWidgets wxString objects) but I haven't worked it out yet.

I hope that I can provide you some feedback soon about the exact corner
cases.

Best regards, Achim



More information about the Boxbackup mailing list