[Box Backup] Error on boxbackup

andrew.habashi at bell.ca andrew.habashi at bell.ca
Thu May 5 15:57:38 BST 2011

The version is Box Backup Client v0.11rc8

And yes the beers will be on me! LOL

Andrew Habashi
Coordination and Programming Specialist | Spécialiste Programmation et Coordination
T : 514 397-6036  M : 514 972-8165
andrew.habashi at bell.ca


-----Original Message-----
From: Nicholas-Karl [mailto:magickarle at hotmail.com] 
Sent: May 4, 2011 11:48 PM
To: 'Box Backup'
Cc: Habashi, Andrew (6038733); 'James O'Gorman'
Subject: RE: [Box Backup] Error on boxbackup

Hey guys.
I worked with Andrew so I'll clear things up:

Problem with bbstored because the client can be started and it generates
bbstored on a DIFFERENT PC then the client.

Check what`s the version by connecting to dubaibck host as root (boxbackup
server box) and run bbstored -V to get the version.
I'm pretty sure it's 0.11

The initiation scripts were put on both boxes in init.d

Boxbackup server running on Centos 5 and client on RedHat enterprise 4

BBSTORED CANNOT BE STARTED. I have tried several times, rebooting server,
tried with the init.d file and the daemon.
I've even tried to recopy the init.d file.
When started manually, it will show an Ok in green but nothing is logged and
ps aux|grep bb shows nothing.

This happened originally when the server was moved and the IP changed.
Last time this happened, I changed the IP address in the hosts file on both
boxes, restarted server and client and voila, it worked again.
But this time it doesn't.
It was running fine for over one year!
I would like to see at least some logs about bbstored not being able to
start so we can pinpoint to a maybe corrupt file of bbstored.

Is there a way to verberos the output of the init.d script file when
starting (beside the -V) ?

Thanks again guys for the time spend on this.
Andrew, you own me AND James a beer :)
I'll remind you next time we see each other hehe!

-----Original Message-----
From: boxbackup-bounces at boxbackup.org
[mailto:boxbackup-bounces at boxbackup.org] On Behalf Of Chris Wilson
Sent: May-04-11 6:29 PM
To: Box Backup
Cc: andrew.habashi at bell.ca; 'James O'Gorman'
Subject: Re: [Box Backup] Error on boxbackup

Hi Andrew,

On Tue, 3 May 2011, andrew.habashi at bell.ca wrote:

> Any news on this?

I'll try to help if I can. It would help a lot if you could tell me the 

Is the problem with bbackupd or bbstored? Are they both on the same 
machine? Are they supposed to be running on the same machine? If so, why? 
Box Backup is a network backup program, most of the benefits are 
irrelevant if you're running both parts on the same machine.

You have /usr/local/sbin/bbstored, do you also have 
/usr/local/bin/bbackupd? What versions do they report if you run them with 
the -V option?

Do these binaries match the ones in 
/usr/src/boxbackup-0.10/release/bin/bbackupd/bbackupd and 
/usr/src/boxbackup-0.10/release/bin/bbstored/bbstored, or the ones in 
/usr/src/boxbackup-0.11rc8/release/bin/bbstored/bbstored, or neither?

Do you have a script in /etc/init.d that starts either bbackupd or 
bbstored or both? If so, please could you attach it to your email?

Is the server running Red Hat Enterprise Linux, or CentOS, or something 
else? Which version?

>> I do /usr/local/sbin/bbstored -D -V and it just goes back to another 
>> command line, I don't get the error /usr/local/sbin/bbstored: No such 
>> file or directory

Is bbstored running before you do this? Is it running afterwards?

And just to confirm, if you run "bbackupd -D -V" you get absolutely no 
output either?

Cheers, Chris.
_____ __     _
\  __/ / ,__(_)_  | Chris Wilson <chris+sig at qwirx.com> Cambs UK |
/ (_/ ,\/ _/ /_ \ | Security/C/C++/Java/Ruby/Perl/SQL Developer |
\__/_/_/_//_/___/ | We are GNU : free your mind & your software |
Boxbackup mailing list
Boxbackup at boxbackup.org

More information about the Boxbackup mailing list