[Box Backup] VSS on x64 not working with x86 binaries

Chris Wilson chris at qwirx.com
Sun Oct 23 23:33:41 BST 2011


Hi Achim,

> It basically requires installing VS Express, then Windows SDK 7.1, then
> starting VS2010 from within the SDK cmd.exe (after switching to x64
> development in cmd.exe), and finally adding a new "Configuration" for
> x64.

How did you add the new configuration? I can't see that option.

> Some hiccups do occur that ultimately prevent uploading files because of 
> a failed ASSERT (see details below), but it appears to me that they are 
> fixable. I have a full TRACE log available, can I send that to you Chris 
> off-list, in addition to the notes I took on how to create the build 
> environment?

I've just checked in a change that should fix the assertion error, I hope.

> This happened when I ctrl-c'ed one bbackupd.exe instance, and then
> immediately started it again. Not sure that I can reproduce, it might
> just be a Windows limitation that it was still trying to clean up the
> old snapshot bbackupd.exe had just created. This is perhaps not really
> relevant at the moment:
>
> 2011-10-21 22:15:03 [TRACE]   VSS: dependencies: 0
> 2011-10-21 22:15:03 [ERROR]   VSS: Failed to start snapshot set:
> IDispatch error #8470 (0x80042316)

Yes, I think this is a temporary Windows problem. Unless we see it again, 
let's assume Windows will clean up after the dead process by itself.

Cheers, Chris.
-- 
_____ __     _
\  __/ / ,__(_)_  | Chris Wilson <chris+sig at qwirx.com> Cambs UK |
/ (_/ ,\/ _/ /_ \ | Security/C/C++/Java/Ruby/Perl/SQL Developer |
\__/_/_/_//_/___/ | We are GNU : free your mind & your software |



More information about the Boxbackup mailing list